PowerShell Versionen

Die Powershell ist teil der Verwaltungswerkzeuge und kommen mit der jeweiligen Version des Betriebssystems erst einmal mit. Aber unabhängig von dem Release-Zyklus des Betriebssystems gibt es auch Updates der PowerShell außer der Reihe. Zudem gibt es Abhängigkeiten zu Drittprodukten wie Exchange, Skype for Business u.a. Es ist nicht ganz leicht hier eine Matrix aktuell zu halten. Ich bin für Hinweise entsprechend Dankbar

Generell gilt auch hier, dass Kombinationen, die Microsoft nicht getestet hat, als "not supportet" eingestuft sind. Beachten Sie, dass auch Abhängigkeiten zum Exchange Updates und .NET Service Pack bestehen. Maßgeblich sind immer die Beschreibungen von Microsoft auf den verschiedenen Webseiten. Ich habe die Seite erst im Jahr 2018 angefangen. Ich werde daher wohl nicht die älteren Exchange Version nachtragen.

WMF/PowerShell Version Released mit Windows Exchange Lync/SfB SharePoint SCCM  

1.0

Jahr 2006
gesonderter Download
erfordert Net 2.0.50727

  • 2003SP1

  • ?

  • nein

  • ?

  • ?

  • ?

2.0


erfordert Net 2.0.50727

  • Vista SP1
  • 8.0, 8.1
  • 2012, 2012R2

  • 2007

  • 2010

  • ?

  • ?

  • ?

3.0
enthält 2.0

Windows 8.0
Windows 2012
erfordert Net 4.5+

  • 7SP1
  • 2008 SP2
  • 2008R2 SP1

  • 2013

  • 2013

  • ?

  • ?

  • ?

4.0
enthält 2.0

Windows 8.1
Windows 2012R2
erfordert Net 4.5+

  • 7SP1, 8.1
  • 2008R2SP1
  • 2012R2

  • 2007
  • 2010

  • 2015

  • ?

  • ?

  • ?

5.0

Windows 2016
erfordert Net 4.5+

  • 7,8.1, 10
  • 2008R2
  • 2012, 2012R2
  • 2016

  • nein

  • nein

  • 2013

  • 2012

  • ?

5.1

Windows 2016
erfordert Net 4.5.2

  • 7,8.1, 10
  • 2008R2
  • 2012, 2012R2
  • 2016

  • ?

  • 2015
    nur auf Win2012R2

  • 2013

  • 2012

  • ?

6.0 (Core)

gesondert

  • 7,8,8.1,10
  • 2008R2
  • 2012R2, 2016
  • diverse Linux

  • ?

  • ?

  • ?

  • ?

  • ?

 

Weitere Links